sharepoint 2013 Arşiv

Belgelerin İstemci Uygulamasında Açılmasının Sağlanması

SharePoint web uygulamalarınızda dosyalarınız varsayılan olarak istemci uygulamasında açılabilmesi için temel bir dizi işlemi gerçekleştirmeniz gerekebilir. Öncelikli olarak bu işlemi kütüphane seviyesinde gerçekleştirmek için kütüphanenizin ayarlar bölümünden işlem yapabilirsiniz.

Kütüphane > Ayarlar > Gelişmiş Ayarlar > Belgeleri Tarayıcıda Açma bölümünden seçiminizi yapabilirsiniz.

 

Bu işlemin site seviyesinde gerçekleşebilmesi için site koleksiyonu özellikleri içerisinden “Belgeleri Varsayılan Olarak İstemci Uygulamada Aç” özelliğini aktive edebilirsiniz.

Yapacağınız bu işlem site koleksiyonunda yaratılacak yeni belge kitaplıklarında ilk maddede yaptığımız ayarda olduğu gibi varsayılan olarak istemci uygulamada açma ayarını düzenleyecektir. Ancak mevcut kütüphaneler için maalesef işe yaramayacak. Bu durumda her bir kütüphane için manuel olarak bu işlemi gerçekleştirebilir veya aşağıdaki gibi bir PowerShell script ile bu işlemin otomatik yapılmasını sağlayabilirsiniz.

 

2010-to-2013-to-2016 SharePoint Migration

Uzun zamandır biliyoruz ki SharePoint ürününde en fazla bir üst versiyona içerik veritabanı yükseltme yöntemiyle yükseltme çalışması gerçekleştirebiliyoruz. Yani SharePoint 2010’dan SharePoint 2016’ya doğrudan yükseltme işlemini yapmak istiyorsak içerik veritabanı yükseltme yöntemini dolaylı yoldan kullanabiliyoruz. Bunun için önce 2010’daki içerik veritabanınızı SharePoint 2013’e, ardından da SharePoint 2013’e yükselttiğiniz veritabanını 2016’ya yükselterek işlemi sağlayabilirsiniz. Burada doğrudan yükseltmenin sağlanabilmesi için ise pek çok ücretli ürün bulunuyor. (ShareGate, Metalogix, vb)

Bu yazıda temel almak istediğim şey yükseltmenin nasıl yapılacağı değil. Bazen yükseltme yaptığınızı varsaydığınızda bile ilerleyen dönemde yarım kalmış operasyonlar sebebiyle sorun yaşayabiliyorsunuz. Örnek bir senaryo üzerinde çalışalım;

Senaryo: SharePoint 2010 olan uygulamamızı içerik veritabanı yükseltme yöntemini kullanarak SharePoint 2013’e yükselttik. Aradan birkaç yıl geçti ve şimdi de SharePoint 2016’ya yükseltme yapmayı deniyoruz.

Bu senaryo için karşılaşabileceğiniz bir senaryo olarak Mount-SPContentDatabase komutu sonrası aşağıdaki hata mesajını görüyor olabilirsiniz.